Back to overview
Downtime

Peloton outage

Nov 2, 2023 at 6:16pm UTC
Affected services
Peloton
Peloton

Resolved
Nov 5, 2023 at 12:07am UTC

Peloton has recovered from service outage.

Created
Nov 2, 2023 at 6:16pm UTC

Peloton services are experiencing outage. https://status.onepeloton.com/