Google Cloud outage
Resolved
Jun 13 at 11:07am BST
Junction API and services remain healthy since the last update.
Google Cloud had declared full incident resolution at 12 Jun 2025 18:27 PDT.
Affected services
US
EU
Dashboard
Updated
Jun 13 at 12:00am BST
Google Cloud is recovering from a global incident earlier today, which affects both the Junction US and EU API region.
- Lab Testing API and Device API remain healthy since the last update.
- Order and Lab Result processing remain healthy since the last update.
- Device Data processing backlog had been cleared, and has resumed normal.
Google Cloud has not yet declared incident resolution. We will continue to monitor the situation.
Affected services
US
EU
Dashboard
Updated
Jun 12 at 10:18pm BST
Google Cloud is recovering from a global incident earlier today, which affects both the Junction US and EU API region.
- Lab Testing API and Device API calls have resumed normal.
- Order and Lab Result processing have resumed normal.
- Device Data processing is recovering.
Google Cloud has not yet declared incident resolution. We will continue to monitor the situation.
Affected services
US
EU
Dashboard
Created
Jun 12 at 07:17pm BST
Google Cloud has reported incidents affecting several critical components that Junction relies on.
As a result:
Junction API calls, including the entire Device API and Lab Testing API, may be unavailable or may experience high latency.
Device Data and Lab Result processing may be disrupted. Work will be queued and re-processed once the incident is resolved.
We are monitoring the situation.
Affected services
US
EU
Dashboard