Back to overview
Downtime

Freestyle Libre integration downtime

Jun 27 at 01:10pm BST
Affected services
Freestyle Libre
Freestyle Libre

Resolved
Jun 27 at 03:21pm BST

The Libre integrations have fully recovered.

Updated
Jun 27 at 01:25pm BST

The Libre integrations are recovering. We are monitoring the status.

Created
Jun 27 at 01:10pm BST

Libre integrations are experiencing a critical issue since 11:00 UTC. We are working with our partners to resolve this.