Back to overview
Degraded

Quest Diagnostics Appointment Scheduling API Intermittent Outage

Sep 03 at 05:51pm BST
Affected services
US

Resolved
Sep 03 at 10:43pm BST

The outage affecting the Quest Appointment API has now been fully resolved.
Thank you for your patience while we monitored the situation, and we’re sorry for any disruption this may have caused.

Updated
Sep 03 at 06:53pm BST

This issue is still ongoing. We are continuing to investigate.

Created
Sep 03 at 05:51pm BST

Quest Diagnostics is currently experiencing an outage with its Appointment Scheduling API. The following endpoints are impacted:
- /v3/order/psc/appointment/availability
- /v3/order/{order_id}/psc/appointment/book
- /v3/order/{order_id}/psc/appointment/reschedule
- /v3/order/{order_id}/psc/appointment/cancel
- /v3/order/psc/appointment/cancellation-reasons
- /v3/order/{order_id}/psc/appointment
The issues are intermittent and returning 500 errors.
Our team is actively monitoring the situation, and we’ll share updates as soon as they’re available.