Back to overview
Degraded

Quest Diagnostics Appointment Scheduling API Intermittent Outage

Sep 07 at 06:53pm BST
Affected services
US

Resolved
Sep 08 at 09:18pm BST

Hi everyone,

The earlier outage affecting the Quest Diagnostics Appointment Scheduling has resolved. The API has been resumed full operation since 07:00 AM ET.

Thank you for your patience while we monitor the recovery and stability of upstream Quest API Appointment Scheduling services over the past few hours, and we’re sorry for any disruption this may have caused! Please let us know if you have any further issues.

—The Junction Team

Created
Sep 07 at 06:53pm BST

Quest Diagnostics Appointment Scheduling API is experiencing an outage since Sunday September 7 07:30 AM ET.

The following Junction API endpoints are impacted:
- /v3/order/psc/appointment/availability
- /v3/order/{orderid}/psc/appointment/book
- /v3/order/{order
id}/psc/appointment/reschedule
- /v3/order/{orderid}/psc/appointment/cancel
- /v3/order/psc/appointment/cancellation-reasons
- /v3/order/{order
id}/psc/appointment

The issues are intermittent and you may observe 500 Internal Server Error responses.

Our team has escalated this issue with Quest, and is monitoring the situation for a resolution. We will provide updates as they become available.