Back to overview
Downtime
Disruption of Libre connections in the EU region
Sep 30 at 11:02pm BST
Affected services
Freestyle Libre
Updated
Oct 09 at 10:32am BST
A fix has been rolled out for the issue affecting Libre connections. All connections are restored and data ingestion is healthy. We’re monitoring closely for any recurrence.
Affected services
Created
Sep 30 at 11:02pm BST
Libre connections in the EU region are experiencing disruptions. We are investigating the issue
Affected services