Junction US Order Creation issue
Resolved
Apr 7, 2026 at 9:44pm UTC
Resolved: Order Creation Issues
The issue impacting order creation has been fully resolved.
This was caused by Google's upstream address validation service returning unexpected / non-standard responses which led to failures during order creation.
Google has declared full resolution as of Tuesday, 2026-04-07 13:37 PDT (https://issuetracker.google.com/issues/500445881) and we've validated that order creation is now functioning normally and we will continue to monitor closely to ensure stability.
If you continue to experience any issues, please reach out to our support team.
Thank you for your patience while we worked through this.
-The Junction Team
Affected services
Updated
Apr 7, 2026 at 8:56pm UTC
Update: Walk-In Order Creation
The issue impacting order creation has been mitigated for walk-in orders, and creation for these orders should now be functioning normally.
This was caused by a disruption with an upstream address validation service. We’ve implemented a mitigation and are continuing to investigate and work toward a full resolution.
Please reach out if you’re still experiencing any issues. We’ll share further updates as we have them.
Affected services
Created
Apr 7, 2026 at 8:19pm UTC
We’re currently investigating an issue impacting lab order creation.
Our team has identified that requests are failing during address validation due to an issue with an upstream service. As a result, some customers may see errors when attempting to create new orders.
What’s impacted
* New order creation flows that rely on address validation
What’s not impacted:
- Existing orders
- Results / downstream order processing for already-created orders
We’re actively investigating and will share another update as soon as we have more information. Thanks for your patience.
Affected services