Back to overview
Degraded
Quest PSC Appointment Booking outage
Apr 16, 2026 at 10:21pm UTC
Affected services
US
Resolved
Apr 17, 2026 at 12:01am UTC
Quest Booking API outage has been resolved. We continue to monitor and will provide a breakdown of the incident when possible.
Affected services
Created
Apr 16, 2026 at 10:21pm UTC
Junction has detected an active incident with Quest's booking API.
All appointment booking endpoints for Quest (walk-in appointments) are affected. You may experience an increased rate of 5XXs during this period.
We've reached out to Quest for further information and resolution.
We will keep you posted on further developments.
-The Junction Team
Affected services