Monitoring
Labcorp had identified the root cause and rolled back the changes. We are observing recovery since 5:07 PM ET. The requisition creation backlog will resume automatically.
Identified
Labcorp requsition creation is delayed due to an Labcorp Aperture API issue.