Quest’s scheduling service has returned to normal operation, and our PSC Appointment Availability and Book PSC Appointment endpoints are functioning as expected. Any requests that failed during the incident will need to be retried. We will continue monitoring the service to ensure it remains stable.
Resolved
Quest’s scheduling service has returned to normal operation, and our PSC Appointment Availability and Book PSC Appointment endpoints are functioning as expected. Any requests that failed during the incident will need to be retried. We will continue monitoring the service to ensure it remains stable.
Investigating
We are investigating a reported outage.
Affected service: Lab Partners → Quest
Affected API regions: US
Synchronous operations of PSC Appointment API may experience a high level of errors. Async Confirmation may cancel the pending appointment if confirmation timeout is exceeded during the incident. PSC Availability Cache may return stale information or error.