Junction

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
US: Lab Partners → Quest
Resolved·Degraded performance
Sun, Aug 9, 2026, 05:55 AM
(1 month ago)
·
Affected components
Aug 9, 2026, 01:17 AM
05:55 AM
Updates

Resolved

The incident with Lab Partners → Quest in the US region has been resolved.

(not set)

Sun, Aug 9, 2026, 05:55 AM

Investigating

We are investigating a reported outage.

Affected service: Lab Partners → Quest

Affected API regions: US

Requisition creation for new orders may be delayed.

Sun, Aug 9, 2026, 01:17 AM(4 hours earlier)